2011-09-08T23:04:04の更新内容

programming/mono/build_install/monodevelop-2.6/index.wiki.txt

current previous
1,9 1,9
 
${smdncms:title,MonoDevelop 2.6 のビルド・インストール}
${smdncms:title,MonoDevelop 2.6 のビルド・インストール}
~
${smdncms:keywords,MonoDevelop 2.6,Ubuntu 11.04}
${smdncms:keywords,MonoDevelop 2.6 RC1,Ubuntu 11.04}
~
[[MonoDevelop 2.6:http://monodevelop.com/]]をソースからビルドしてインストールする手順。 検証に使った環境はUbuntu 11.04 (Natty Narwhal) Desktop。
[[MonoDevelop 2.6 RC1:http://monodevelop.com/]]をソースからビルドしてインストールする手順。 検証に使った環境はUbuntu 11.04 (Natty Narwhal) Desktop。
 

        

        
 
-リンク
-リンク
~
--[[Release Notes for MonoDevelop 2.6 - MonoDevelop:http://monodevelop.com/Download/Release_Notes/Release_Notes_for_MonoDevelop_2.6]]
--[[Release Notes for MonoDevelop 2.6 RC1 - MonoDevelop:http://monodevelop.com/Download/Release_Notes/Release_Notes_for_MonoDevelop_2.6_RC1]]
 
--[[Download - MonoDevelop:http://monodevelop.com/Download]]
--[[Download - MonoDevelop:http://monodevelop.com/Download]]
 
--[[What's new in MonoDevelop 2.6 - MonoDevelop:http://monodevelop.com/Download/What%27s_new_in_MonoDevelop_2.6]]
--[[What's new in MonoDevelop 2.6 - MonoDevelop:http://monodevelop.com/Download/What%27s_new_in_MonoDevelop_2.6]]
 
-関連するページ
-関連するページ
13,9 13,8
 
**MonoDevelopが必要とするアセンブリのインストール
**MonoDevelopが必要とするアセンブリのインストール
 
MonoDevelopが必要とするアセンブリをあらかじめインストールしておく。 必要になるものは以下のアセンブリ。 各アセンブリのインストール方法については[[programming/mono/build_install/mono-2.10]]を参照のこと。
MonoDevelopが必要とするアセンブリをあらかじめインストールしておく。 必要になるものは以下のアセンブリ。 各アセンブリのインストール方法については[[programming/mono/build_install/mono-2.10]]を参照のこと。
 
-MonoDevelopが必要とするアセンブリ・パッケージ
-MonoDevelopが必要とするアセンブリ・パッケージ
+
--Mono (2.10.4以上)
 
--Mono Addins
--Mono Addins
~
--gtk-sharp (2.12.8以上)
--gtk-sharp
 
--monodoc
--monodoc
 
--gecko-sharp
--gecko-sharp
 
--gtksourceview-sharp
--gtksourceview-sharp
23,9 22,9
 

        

        
 
**ソースのダウンロードとconfigure
**ソースのダウンロードとconfigure
 
#code(sh){{
#code(sh){{
~
wget http://download.mono-project.com/sources/monodevelop/monodevelop-2.6.tar.gz
wget http://monodevelop.com/files/Linux/tarballs/monodevelop-2.5.93.tar.bz2
~
tar -xvf monodevelop-2.6.tar.gz 
tar -xvf monodevelop-2.5.93.tar.bz2 
~
cd monodevelop-2.6/
cd monodevelop-2.5.93/
 
./configure --prefix=/opt/mono/2.10/ --enable-git
./configure --prefix=/opt/mono/2.10/ --enable-git
 
}}
}}